Ford Fiesta ST
Page 1 of 2 1 2 >
Topic Options
Rate This Topic
#163719 - 09/05/09 06:22 PM headlight problem
Robbo Offline
n00b

Registered: 27/08/07
Posts: 46
Loc: Edinburgh
Hey

Im having a problem with my headlights... mk6 56 plate fiesta st...

Basically, every light works; indicators, full beam (when you pull the stick back), side lights and fog lights. But my head lights don't work. Both of them went at the same time. Hmm.

I've checked the fuses behind the glove box, they're fine. I've tried to change the bulbs themselves, and the new bulbs didn't work either. I'm stumped, please help?
_________________________
56 Plate - Standard ST :: POW!

Top
#163720 - 09/05/09 06:40 PM Re: headlight problem [Re: Robbo]
Adam08 Offline
Site Supporter

Registered: 15/10/08
Posts: 14823
Loc: Harpenden, Hertfordshire
My mate has the exact same problem haven't managed to solve it yet though
_________________________


Coming soon
TD GT28/32 hybrid turbo, 3inch decat, air intake, injectors, fuel pump, tubular manifold

Top
#163721 - 10/05/09 08:28 AM Re: headlight problem [Re: Adam08]
crispymk2 Offline


Registered: 05/05/09
Posts: 61
Loc: Perth, Western Australia
have you tried checking and cleaning all the connectors and chcking the earths? Could be a fault inside the switch too, you have eliminated the bulbs and fuses so it must be the switch or connectors you would think?
_________________________

Top
#163722 - 10/05/09 11:04 AM Re: headlight problem [Re: crispymk2]
Dazzyb Offline


Registered: 23/02/09
Posts: 125
Loc: Hampshire
Sounds like the light switch it's self. All computerized now days so more likely to be the light switch as it has it's own control unit built in.
_________________________
06 ST White mods so far:Privacy glass,Black ST wheels with blue rim,EcoTec valve,K&N induction kit,Pipercross breather filter,Miltek flexi,Scorpion cat back.ordered BLUEFIN. Next on the list:12.5mm spacers,Exhaust,springs

Top
#163723 - 10/05/09 12:16 PM Re: headlight problem [Re: Dazzyb]
DAVE T ST Offline
Fiesta Nutter

Registered: 15/01/06
Posts: 3556
Loc: Tipton nr. Dudley, W. Mids
Have you got auto lights?

Sounds like a GEM glitch, possibly the relay on the GEM has gone.

GEM is mounted to the x car beam above the throttle pedal, have a look.
_________________________
2011 Focus 3-door Zetec 1.6 TDCi. Previous s - 2006 Panther Black & 2007 Red. Gone and quite forgotten

Top
#163724 - 10/05/09 04:21 PM Re: headlight problem [Re: DAVE T ST]
Robbo Offline
n00b

Registered: 27/08/07
Posts: 46
Loc: Edinburgh
auto lights? - im assuming that switches your lights on automatically - in which case no, i just have the standard switch.

Okay I'll check the relay, what am i looking for? will it be like when a fuse has blown?
_________________________
56 Plate - Standard ST :: POW!

Top
#163725 - 11/05/09 07:09 AM Re: headlight problem [Re: Robbo]
DAVE T ST Offline
Fiesta Nutter

Registered: 15/01/06
Posts: 3556
Loc: Tipton nr. Dudley, W. Mids
No you have to swap them with one that you know works and see if the lights come on.
_________________________
2011 Focus 3-door Zetec 1.6 TDCi. Previous s - 2006 Panther Black & 2007 Red. Gone and quite forgotten

Top
#163726 - 11/05/09 07:24 AM Re: headlight problem [Re: DAVE T ST]
Robbo Offline
n00b

Registered: 27/08/07
Posts: 46
Loc: Edinburgh
which relay is the one for the headlights? - what are the other relays for? (i think there are 4 there).

- any other idea's if it turns out not to be them? I will check this out when i head for lunch today.
_________________________
56 Plate - Standard ST :: POW!

Top
#163727 - 11/05/09 08:40 AM Re: headlight problem [Re: Robbo]
DAVE T ST Offline
Fiesta Nutter

Registered: 15/01/06
Posts: 3556
Loc: Tipton nr. Dudley, W. Mids
Socket C417 on the GEM is the dipped beam relay, take it out and swap it for the high beam relay and see if the lights work.

Failing that it could be the indicator stalk has gone, though this is rare as they are quite reliable.

You can enter a diagnostic mode within the GEM but I don't know if it will help you.
This is for a face-lift ST if yours isn't facelift don't do it



A diagnosis of the generic electronic module (GEM) can be performed with the Ford diagnostic equipment. Furthermore, an integrated service mode enables testing of the input and output signals without the need for further tools. To enable activation of service mode:

Switch off the ignition,
Switch off all other electrical consumers,
Apply the handbrake,
Shift to neutral
Close the doors.
Activating the service mode

Proceed as follows to activate the service mode:

OPERATE the switch of the heated rear window and HOLD IT THERE
Turn on the ignition.
RELEASE the switch of the heated rear window
PRESS the heated rear window switch 8 times within 6 seconds
A signal sounds and the turn signal lamps flash to indicate that service mode has been successfully activated.

Input signals

SWITCH the wiper switch to the "Off" position to test the input signals. The following is a list of the signals to be tested, in no particular order:

Turn signals (right, left, hazard warning lights)
"Lights on" warning (terminal 58)
Windshield wiper (intermittent wipe)
Windshield washer system
Rear window wiper
Rear window washer system
Doors/tailgate open/closed
Central locking
Hood open/closed (in vehicles equipped with an anti-theft alarm system)
Front fog switch (if fitted)
Rear fog switch
Heated rear window
Heated windscreen (if fitted)
An acoustic signal sounds and the turn signal lamps flash to indicate receipt of each input signal by the generic electronic module.

Output signals

SWITCH the wiper switch to the "Intermittent" position to test the output signals. PRESS the heated rear window switch activates or deactivates the output signals in the following order:

Windshield wipers (a signal sounds and the direction indicator lamps flash when the "Park" position is reached)
Heated rear window
Interior light(s) (the interior light switch must be in the "ON" position)
Rear window wiper
heated windshield (if fitted, is only activated when engine is running)
If the heated rear window switch is operated again, the sequence restarts with point 'a' and the functions are activated again in this order.

Ending the service mode

The GEM automatically ends service mode 20 seconds after the last input. However, service mode can be manually ended at any time by proceeding as follows:

OPERATE the switch of the heated rear window and HOLD IT THERE
SWITCH OFF the ignition
RELEASE the switch of the heated rear window
3 signals sound and the turn signal lamps illuminate to indicate that service mode has ended.
_________________________
2011 Focus 3-door Zetec 1.6 TDCi. Previous s - 2006 Panther Black & 2007 Red. Gone and quite forgotten

Top
#163728 - 11/05/09 09:09 AM Re: headlight problem [Re: DAVE T ST]
Dan_The_Man Offline
Site Supporter

Registered: 20/10/08
Posts: 7257
Loc: Eaton Bray, Dunstable
if you were to by a switch that had the auto option would the wiring be there for them to work?
_________________________

Top
#163729 - 11/05/09 11:48 AM Re: headlight problem [Re: Dan_The_Man]
DAVE T ST Offline
Fiesta Nutter

Registered: 15/01/06
Posts: 3556
Loc: Tipton nr. Dudley, W. Mids
Mmmm some of it, not all.
Depends on what other options the car had fitted (Powerfolds etc etc)

You would also need a rain sensor and a new windscreen to mount the rain sensor to.

They both talk to the GEM and the unique ST150(UK) GEM (Thatcham 1 support)
supports it.

You would probably need the GEM flashing to tell it the rain/light sensor is there.
_________________________
2011 Focus 3-door Zetec 1.6 TDCi. Previous s - 2006 Panther Black & 2007 Red. Gone and quite forgotten

Top
#163730 - 11/05/09 01:13 PM Re: headlight problem [Re: DAVE T ST]
Robbo Offline
n00b

Registered: 27/08/07
Posts: 46
Loc: Edinburgh
well i doubt it'll be the indicator stalk because my lights are operated by the dail thing to the right of the steering wheel.

thanks for that though! I will have a look/play tonight when im home from work (if the weather stays like this!).

Im assuming if I took this problem to ford it'll cost me a ridiculous amount just to have it looked at.
_________________________
56 Plate - Standard ST :: POW!

Top
#163731 - 11/05/09 04:54 PM Re: headlight problem [Re: Robbo]
Robbo Offline
n00b

Registered: 27/08/07
Posts: 46
Loc: Edinburgh
okay 2 questions:

1) Which socket is C417. I see 5 of them and they aren't labelled!

2) How do I get them off, i can see a sticker saying "Scrap if dropped more than 20cm", so im assuming its mega fragile 'n therefore I don't wanna be prodding or tugging at it!
_________________________
56 Plate - Standard ST :: POW!

Top
#163732 - 11/05/09 06:47 PM Re: headlight problem [Re: Robbo]
Adam08 Offline
Site Supporter

Registered: 15/10/08
Posts: 14823
Loc: Harpenden, Hertfordshire
If they are black boxes like they are on the noble then they just pull out
(as the noble is mainly ford parts)
_________________________


Coming soon
TD GT28/32 hybrid turbo, 3inch decat, air intake, injectors, fuel pump, tubular manifold

Top
#163733 - 11/05/09 09:25 PM Re: headlight problem [Re: Adam08]
Dan_The_Man Offline
Site Supporter

Registered: 20/10/08
Posts: 7257
Loc: Eaton Bray, Dunstable
i was meaning just the lights i wouldn't want auto wipers as some company cars iv used have had them i just turn them off as they always come on at the wrong times!
_________________________

Top
Page 1 of 2 1 2 >

Moderator:  Duncan_P, kenny, Kev 
Search

Who's Online
8 registered (Acton, dontpannic, FOCAR, ryant, redstLee, ROB IS THE STIG, watkja, 1 invisible), 214 Guests and 0 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Featured Member
Registered: 09/11/09
Posts: 8278
Today's Birthdays
No Birthdays
Newest Members
Rowland39, Lukeyd93, hijklm481854, smiler24, Neill
6441 Registered Users
Top Posters (30 Days)
ROB IS THE STIG 425
sxkopite8 167
watkja 155
BlondeBexx 143
ChrisCumbria 139
kenny 133
Scotty 132
dontpannic 82
redstLee 55
YellowBadge 50
Top Posters
ROB IS THE STIG 47558
ChrisCumbria 20806
Scotty 17379
Alex_H 15061
Adam08 14823
babyboom 11557
Micky 11552
steviehouse 11221
kenny 10332
Kev 10187
Forum Stats
6442 Members
53 Forums
30605 Topics
541698 Posts

Max Online: 477 @ 19/03/14 10:32 PM