Ford Fiesta ST
Page 2 of 2 < 1 2
Topic Options
Rate This Topic
#159131 - 26/04/09 09:44 PM Re: EAC Fault, help please [Re: DAVE T ST]
sim Offline


Registered: 26/03/09
Posts: 439
Just the throttle body, I shall be doing the connectors this week. Also hopefully get my fault reader tomorrow or Tuesday so can see what code that throws out. Is there a list of the codes somewhere?

Top
#159132 - 27/04/09 07:19 AM Re: EAC Fault, help please [Re: sim]
DAVE T ST Offline
Fiesta Nutter

Registered: 15/01/06
Posts: 3556
Loc: Tipton nr. Dudley, W. Mids
Yes, they're in "how to"
_________________________
2011 Focus 3-door Zetec 1.6 TDCi. Previous s - 2006 Panther Black & 2007 Red. Gone and quite forgotten

Top
#159133 - 27/04/09 05:41 PM Re: EAC Fault, help please [Re: DAVE T ST]
Kev Offline



Registered: 01/03/06
Posts: 10277
Loc: Birmingham, UK.
_________________________

Top
#159134 - 27/04/09 11:05 PM Re: EAC Fault, help please [Re: Kev]
sim Offline


Registered: 26/03/09
Posts: 439
Excellent, thanks guys!

Top
#159135 - 19/05/09 08:38 AM Re: EAC Fault, help please [Re: sim]
sim Offline


Registered: 26/03/09
Posts: 439
Well I just caught an EAC Fail and had my fault code reader in at the time it happened, however the reader said No Faults.... Broken reader or a silly Fiesta error? Dave?

Top
#159136 - 19/05/09 10:02 AM Re: EAC Fault, help please [Re: sim]
DAVE T ST Offline
Fiesta Nutter

Registered: 15/01/06
Posts: 3556
Loc: Tipton nr. Dudley, W. Mids
It's the connector's they need cleaning. Especially the throttle pedal connector, I know Fiesta/Fusion had an issue with this until 2006.5my when they changed the plug pins and pedal to gold connectors as the Air Con can cause condensation in the connectors.

For a split second you get a miss-connection which throws the lights up then it re-connects and shuts them off again.

Certain faults are given priority (safety critical parts etc etc).

Some components need to be faulty once to put the lamp up
Some need five driving cycles (key out-key in)
Some need twelve.
Some put codes up as a notification that there WAS an issue, whereas some are live.

You need to disconnect the battery earth (-) terminal and disconnect and clean/spray the following connectors AND ports:

Throttle body
Throttle Pedal
Alternator

then re-connect the battery.

Failing that then the motor is on the way out on the throttle body.
_________________________
2011 Focus 3-door Zetec 1.6 TDCi. Previous s - 2006 Panther Black & 2007 Red. Gone and quite forgotten

Top
#159137 - 19/05/09 01:24 PM Re: EAC Fault, help please [Re: DAVE T ST]
sim Offline


Registered: 26/03/09
Posts: 439
Thanks for the help Dave. I shall spray all the connectors this weekend as I have a day dedicated to getting my car looking good again.

I suspect it might be a new TB as after I cleaned it, I didn't get the EAC fail for a couple of weeks. I shall see how I get on though and let you know.

Cheers

Top
#159138 - 19/05/09 01:58 PM Re: EAC Fault, help please [Re: sim]
sim Offline


Registered: 26/03/09
Posts: 439

Top
#159139 - 19/05/09 05:04 PM Re: EAC Fault, help please [Re: sim]
DAVE T ST Offline
Fiesta Nutter

Registered: 15/01/06
Posts: 3556
Loc: Tipton nr. Dudley, W. Mids
That'll do it.

As long as it says it's suitable for electronics.

You may want to silicon grease the throttle pedal and body connectors as well after you have lubricated. To keep future moisture out.

Remember to do it with the battery disconnected and to connect/disconnect the connectors a few times to really clean/settle the contacts.

You haven't had the engine bay jet washed at all have you?
_________________________
2011 Focus 3-door Zetec 1.6 TDCi. Previous s - 2006 Panther Black & 2007 Red. Gone and quite forgotten

Top
#159140 - 19/05/09 08:21 PM Re: EAC Fault, help please [Re: DAVE T ST]
sim Offline


Registered: 26/03/09
Posts: 439
Ok, I'll do that.

Nope, I've never jet washed the engine. Why do you ask?
Don't think the previous owner did either, don't think the previous owner actually looked after the car properly

Top
Page 2 of 2 < 1 2

Moderator:  Duncan_P, kenny, Kev 
Search

Who's Online
7 registered (Dan_The_Man, Jack_P, watkja, sxkopite8, Blechdosenbill, motocrossmad, ROB IS THE STIG), 260 Guests and 0 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Featured Member
Registered: 20/03/14
Posts: 18
Today's Birthdays
No Birthdays
Newest Members
klmnop146829, landwomble, Kettle, Eivind, ADB91
6688 Registered Users
Top Posters (30 Days)
ROB IS THE STIG 270
watkja 97
ChrisCumbria 73
kenny 67
BlondeBexx 66
dontpannic 44
Scotty 34
Acton 34
Dan_The_Man 31
Oyvind 30
Top Posters
ROB IS THE STIG 48581
ChrisCumbria 21077
Scotty 17605
Alex_H 15061
Adam08 14823
babyboom 11557
Micky 11552
steviehouse 11312
kenny 10528
Kev 10277
Forum Stats
6689 Members
55 Forums
30827 Topics
545731 Posts

Max Online: 477 @ 19/03/14 10:32 PM