Ford Fiesta ST
Topic Options
Rate This Topic
#563717 - 14/09/20 03:15 PM Car goes into limp mode at 4k+
JakeWarrant Offline
Stranger

Registered: 16/07/20
Posts: 1
Loc: United Kingdom
Hi all

I had my car remapped a couple days ago as Iíve gotten a cosworth replica inlet. It was fine on the way home but once I got onto the motorway and was maintaining 4k revs it all of a sudden made a few popping noises and threw itself into limp mode. I turned the engine straight off in a panic and tried to start it again, it fired right up and the check engine light went away. As soon as I got up to 4k revs it had the same issue. I got home using the roads instead of the motorway, and scanned the engine for codes. It gave me p2110.

Now Iíve tried changing as much as I can think of, changed the throttle body, coil pack, spark plugs, and still got the same problem. I even got the old map put back on just incase it was to do with the new map and itís giving the same issue. (Also if I just hold out the revs itíll pull fine through all the gears, only plays up when maintaining anything above 4k, full throttle is fine)

Does anybody have any idea what could be causing this problem? Any help is greatly appreciated!!
Thanks all

Top
#563718 - 15/09/20 08:49 PM Re: Car goes into limp mode at 4k+ [Re: JakeWarrant]
YellowBadge Offline
MountooningTipster

Registered: 26/08/07
Posts: 11485
Loc: here
pretty sure that code is throttle/body related without looking it up, so something is putting the engine into safe mode for protection. I would look at all connections TB wires etc are all fully connected up seeing as a lot of stuff will have come off and gone back on. I'm kind of thinking this is a mapping issue and needs to go back to them, as the ECU is clearly not happy with fueling etc.
_________________________

MR200 Stage 3 200PS
Evans Halshaw
Mountune Pro

Top
#563719 - 16/09/20 01:28 PM Re: Car goes into limp mode at 4k+ [Re: JakeWarrant]
_Jimmy_ Offline
Site Supporter

Registered: 11/02/14
Posts: 1318
Loc: Northwest
Seems a coincidence that it happened after the remap, did they definitely put the old map back on?

Is it possible one of the wires or connectors to the TB was damaged or trapped when you fitted the manifold maybe? Was it OK after fitting the manifold before the remap.

Only thing I could think of as a guess besides the throttle body is the swirl flaps on the manifold that would close at a certain revs, and there will be a connector for it that's now disconnected presumably? But that's just guesswork and may not be anything if the code it's throwing is throttle body related.
_________________________
2005 Fiesta ST
Newman fast road cams, Fusion Fabrications custom inlet manifold, custom exhaust

Top
#563746 - 23/10/20 05:22 PM Re: Car goes into limp mode at 4k+ [Re: JakeWarrant]
Scotty Offline
Porsche 997 Turbo & ST150

Registered: 27/02/04
Posts: 18089
Loc: Nuneaton, Warwickshire
I would definitely retrace steps. Get the front bumper off and get a real good look at everything. Make sure there are is no wires or connections damaged or loose. Also confirm the map was put back.
_________________________

Top
#563759 - Yesterday at 04:35 PM Re: Car goes into limp mode at 4k+ [Re: JakeWarrant]
_Jimmy_ Offline
Site Supporter

Registered: 11/02/14
Posts: 1318
Loc: Northwest
Another suggestion is the EGR can throw up problems if you've removed it if your car is a pre early 2006 model. I think a PCM update cures it. If yours is a later model then it doesn't have one so won't be that.
_________________________
2005 Fiesta ST
Newman fast road cams, Fusion Fabrications custom inlet manifold, custom exhaust

Top

Moderator:  Duncan_P, kenny, Kev 
Search

Who's Online
2 registered (steve_de, ChrisCumbria), 451 Guests and 0 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Featured Member
Registered: 01/03/20
Posts: 3
Today's Birthdays
No Birthdays
Newest Members
Peter17, GJK27, Bobbysmile, D4NST150, panthos
8393 Registered Users
Top Posters (30 Days)
ChrisCumbria 10
YellowBadge 6
_Jimmy_ 5
kenny 4
steve_de 3
Scotty 2
Sids11 1
D4NST150 1
Top Posters
ROB IS THE STIG 50824
ChrisCumbria 23160
Scotty 18089
Adam08 15118
Alex_H 15061
kenny 11632
steviehouse 11614
babyboom 11557
Micky 11552
YellowBadge 11485
Forum Stats
8394 Members
49 Forums
32165 Topics
560844 Posts

Max Online: 5881 @ 31/12/19 02:16 AM